VS:SetTopPlan2DComp

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the 2D component that is shown in Top/Plan view for a symbol definition or plug-in object

                          Table - components:

Component Constant
Top 0
Top and Bottom Cut 1

FUNCTION SetTopPlan2DComp(
objectHandle :HANDLE;
component :INTEGER) : BOOLEAN;
def vs.SetTopPlan2DComp(objectHandle, component):
    return BOOLEAN

Parameters

objectHandle HANDLE Handle to the object.
component INTEGER 2D component to be shown in Top/Plan view.

Return Value

Returns TRUE if the operation was successful.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:GetTopPlan2DComp | VS:Set2DComponentGroup | VS:Get2DComponentGroup

VS Functions:

[[VS:GetTopPlan2DComp]] | [[VS:Set2DComponentGroup]]

| [[VS:Get2DComponentGroup]]