VS:SetTextStyleRefN/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

文字図形のうち指定した部分の文字列がインデックスで指定した文字スタイルを使用するように設定します。文字スタイルを使用しない(解除する)場合は0を指定します。

FUNCTION SetTextStyleRefN(
objectId :HANDLE;
start :INTEGER;
count :INTEGER;
textStyleRef :LONGINT) : BOOLEAN;
def vs.SetTextStyleRefN(objectId, start, count, textStyleRef):
    return BOOLEAN

Parameters

objectId HANDLE 図形のハンドル
start INTEGER 文字列の開始位置(0を基準)
count INTEGER 文字列の長さ
textStyleRef LONGINT 文字スタイルのインデックス

Return Value

図形が存在しないか、指定した文字列の位置が末尾を超えている場合FALSEを、それ以外はTRUEを返します。

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:SetTextStyleRef | VS:GetTextStyleRef | VS:GetTextStyleRefN | VS:SetTextStyleByClass | VS:SetTextStyleByClassN | VS:IsTextStyleByClass | VS:IsTextStyleByClassN

VS Functions:

[[VS:SetTextStyleRef]] | [[VS:GetTextStyleRef]] | [[VS:GetTextStyleRefN]] | [[VS:SetTextStyleByClass]] | [[VS:SetTextStyleByClassN]] | [[VS:IsTextStyleByClass]]

| [[VS:IsTextStyleByClassN]]