VS:SetSymbolOptions

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetSymbolOptions sets the insert and break options for the specified symbol.


Table - Symbol Insertion Options

Insertion Mode Description Constant Value
Insert on Center Line 0
Insert on Edge 1
Break Mode Description Constant Value
Full Break with Caps 1
Full Break No Caps 2
Half Break 3
No Break 4
PROCEDURE SetSymbolOptions(
name :STRING;
insertMode :INTEGER;
breakMode :INTEGER);
def vs.SetSymbolOptions(name, insertMode, breakMode):
    return None

Parameters

name STRING Name of symbol.
insertMode INTEGER Insertion mode of symbol.
breakMode INTEGER Break mode for inserted symbol.

Remarks

Deleted this obsolete function as of 9.0.0b7 - PCP 12-21-2000


Sets the insert and break options for the master symbol named <name>.

The insertMode options are:
0 = insert on the center line of the wall
1 = insert on the edge of the wall

The breakMode options are:
1 = Full break with caps, both edges of the wall are broken and cap lines close off the two broken portions of the wall.
2 = Full break with no caps, both edges of the wall are broken and there are no cap lines.
3 = Half break, for edge insertions only, wall edge is broken on the same edge that the symbol is inserted on.
4 = No break, there is no break in the wall, the symbol is drawn on top of the wall.

See also Get SymbolOptions

[sd 8/18/98]

Version

SetSymbolOptions is obsolete as of VectorWorks8.5


Availability: from VectorWorks8.0