VS:SetRot3D/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した3次元図形を、指定した角度(度数)と軸で回転させます。

柱状体、多段柱状体、回転体で利用できます。

「Set3DRot」と「SetRot3D」の違いは、以下のとおりです。
「Set3DRot」は図形を現在の角度から指定した角度分回転させます。
「SetRot3D」は図形の角度を指定した角度にします。

PROCEDURE SetRot3D(
h :HANDLE;
xAngle :REAL;
yAngle :REAL;
zAngle :REAL;
xDistance :REAL)Coordinate); yDistance:REAL (Coordinate); zDistance:REAL (Coordinate));
def vs.SetRot3D(h, xAngle, yAngle, zAngle, xDistance, yDistance, zDistance):
    return None

Parameters

h HANDLE 3次元図形のハンドル
xAngle REAL X軸方向の角度
yAngle REAL Y軸方向の角度
zAngle REAL Z軸方向の角度
xDistance REAL (Coordinate) 回転軸のX座標
yDistance REAL (Coordinate) 回転軸のY座標
zDistance REAL (Coordinate) 回転軸のZ座標

Version

利用可能バージョン: MiniCAD

See Also

関連関数:

VS:Set3DRot

関連関数: [[VS:Set3DRot]]