VS:SetMarkerChoice/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

マーカポップアップを設定します。角度パラメータは、0から90度の範囲でなければなりません。


VW2008で使用できなくなった関数/手続きです。
SetMarkerValueをご利用ください。

PROCEDURE SetMarkerChoice(
dialogID :LONGINT;
itemID :LONGINT;
index :INTEGER;
style :INTEGER;
angle :INTEGER;
size :REAL);
def vs.SetMarkerChoice(dialogID, itemID, index, style, angle, size):
    return None

Parameters

dialogID LONGINT ダイアログ番号
itemID LONGINT アイテム番号
index INTEGER マーカ番号
style INTEGER スタイル
angle INTEGER 角度(度数)
size REAL 長さ(インチ)

Example

PROCEDURE dialog1_Main;
VAR
	int, dialog1   :INTEGER;
	index, style, angle, size :INTEGER;

PROCEDURE dialog1_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
	CASE item OF
		SetupDialogC:
			BEGIN
				index := 1;
				style := 2;
				angle := 3;
				size  := 4;
				SetMarkerChoice(dialog1, 4, index, style, angle, size);
			END;
		5: 
			BEGIN
				GetMarkerChoice(dialog1, 4, index, style, angle, size);
				AlrtDialog(Concat('index: ', index, Chr(13), 'style: ', style, Chr(13), 'angle: ', angle, Chr(13), 'size: ', size));
			END;
	END;
END;

BEGIN
	dialog1 := CreateLayout('Test', False, 'OK', '');
	CreateMarkerPopup(dialog1, 4);
	CreatePushButton(dialog1, 5, '  Display Values  ');
	SetFirstLayoutItem(dialog1, 4);
	SetBelowItem(dialog1, 4, 5, 0, 2);
	int := RunLayoutDialog(dialog1, dialog1_Handler);
END;
RUN(dialog1_Main);

Version

SetMarkerChoice 廃止バージョン: VectorWorks 2008


利用可能バージョン: VectorWorks12.0

See Also

関連関数:

VS:GetMarkerChoice

関連関数: [[VS:GetMarkerChoice]]