VS:SetFPat/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した図形の面の模様を、指定した模様番号に変更します。


ビットマップは0から71までの正の値で示されています。ハッチングは負の値で示されています。

PROCEDURE SetFPat(
h :HANDLE;
fillPattern :LONGINT);
def vs.SetFPat(h, fillPattern):
    return None

Parameters

h HANDLE 図形のハンドル
fillPattern LONGINT 模様番号

Example

{ Apply a bitmap fill pattern. }
SetFPat(objectOne, 47);

{ Apply a vector fill. }
SetFPat(objectTwo, -Name2Index('My Hatch'));

Version

利用可能バージョン: MiniCAD