VS:SetEntityMatrix/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

プレイナー図形の平面マトリックスを設定します。すでに同じマトリックスを持つ平面が書類中にあれば、オブジェクトはその平面に設定されます。

そうでなければ、書類に新しい平面が設定されます。

FUNCTION SetEntityMatrix(
objectHandle :HANDLE;
offset :POINT3D;
rotationXAngle :REAL;
rotationYAngle :REAL;
rotationZAngle :REAL) : BOOLEAN;
def vs.SetEntityMatrix(objectHandle, offset, rotationXAngle, rotationYAngle, rotationZAngle):
    return BOOLEAN

Parameters

objectHandle HANDLE 平面を設定するオブジェクト
offset POINT3D 現在の書類の単位での平面のオフセット
rotationXAngle REAL X軸周りの平面の回転角度
rotationYAngle REAL Y軸周りの平面の回転角度
rotationZAngle REAL Z軸周りの平面の回転角度

Return Value

渡されたオブジェクトがプレイナー図形の場合にはtrueを返します。

Version

利用可能バージョン: Vectorworks 2011