VS:SetDormerThick/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定したドーマーの、壁と屋根の厚みを設定します。

PROCEDURE SetDormerThick(
roofObject :HANDLE;
wallThickDistance :REAL)Coordinate); roofThickDistance:REAL (Coordinate));
def vs.SetDormerThick(roofObject, wallThickDistance, roofThickDistance):
    return None

Parameters

roofObject HANDLE ドーマーのハンドル
wallThickDistance REAL (Coordinate) 壁の厚み
roofThickDistance REAL (Coordinate) 屋根の厚み

Example

roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-77'10",21'4.81922",#45°0'0",2'0",10'0");
shedID := CreateShedDormer(roofHandle);
SetShedAttributes(roofHandle,shedID,TRUE,6'0",10'0",2'0",#8°0'0");
SetDormerAttributes(roofHandle, shedID, 3,18'4",TRUE,3'0",63,FALSE,3'0");
SetDormerThick(roofHandle, 2",1.83333");

Version

利用可能バージョン: VectorWorks8.0