VS:SetDisplayWith2DComp

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets whether a 3D object in a symbol definition or plug-in object is shown when the specified 2D component is shown.

                                                                                                                      Table - 2D components

2D component Constant
Not Set 0
Top 1
Bottom 2
Top and Bottom Cut 3
Front 4
Back 5
Front and Back Cut 6
Left 7
Right 8
Left and Right Cut 9

FUNCTION SetDisplayWith2DComp(
objectHandle :HANDLE;
component :INTEGER;
isVisible :BOOLEAN) : BOOLEAN;
def vs.SetDisplayWith2DComp(objectHandle, component, isVisible):
    return BOOLEAN

Parameters

objectHandle HANDLE 3D object handle.
component INTEGER 2D component.
isVisible BOOLEAN Visibility of the object when the 2D component is shown.

Return Value

TRUE if the operation succeeded.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Set2DComponentGroup | VS:Get2DComponentGroup

VS Functions:

[[VS:Set2DComponentGroup]]

| [[VS:Get2DComponentGroup]]