VS:SetComponentClass

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the class of a component in an object.

FUNCTION SetComponentClass(
obj :HANDLE;
componentIndex :INTEGER;
componentClass :LONGINT) : BOOLEAN;
def vs.SetComponentClass(obj, componentIndex, componentClass):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
componentClass LONGINT The class of the component.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentClass

VS Functions: [[VS:GetComponentClass]]