VS:RunNamedDialogN

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays the specified dialog with universal name and initiates the dialog event loop. The dialog event loop is specified in a procedure subroutine that is passed as a parameter to the function.

FUNCTION RunNamedDialogN(
dialogID :LONGINT;
callback :PROCEDURE;
univName :STRING;
enableContextualHelp :BOOLEAN) : LONGINT;
def vs.RunNamedDialogN(dialogID, callback, univName, enableContextualHelp):
    return LONGINT

Parameters

dialogID LONGINT The index of the dialog to be displayed
callback PROCEDURE The event loop subroutine for the dialog
univName STRING The universal name of the dialog
enableContextualHelp BOOLEAN Determines whether or not contextual help is accessible

Return Value

Returns a LONGINT value indicating the button pressed to exit the dialog.

Version

Availability: from Vectorworks 2018

See Also

VS Functions:

VS:RunLayoutDialogN

VS Functions: [[VS:RunLayoutDialogN]]