VS:NextLayer/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定したレイヤの次にあるレイヤのハンドルを返します。図形が存在しない場合はNILを返します。

FUNCTION NextLayer(
h :HANDLE) : HANDLE;
def vs.NextLayer(h):
    return HANDLE

Parameters

h HANDLE レイヤのハンドル

Return Value

レイヤのハンドル

Example

handleToLayer:=FLayer;
WHILE handleToLayer <> NIL DO BEGIN
  SysBeep;
  handleToLayer:=NextLayer(handleToLayer);
END; 
{ will process through all the layers in the list }

Version

利用可能バージョン: MiniCAD