VS:LDevice GetParamBool

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get boolean parameter of a Lighting Device or attached Accessory by Worksheet Name. Use cell index 0 to operate on the first cell. Cell index -1 is not supported for Get.

Use accessory index -2 to ignore accessory values. Use accessory index 0 to operate on the first accessory of the specified cell. Accessory index -1 is not supported for Get.

FUNCTION LDevice_GetParamBool(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
universalName :STRING) : BOOLEAN;
def vs.LDevice_GetParamBool(handle, cellIndex, accessoryIndex, universalName):
    return BOOLEAN

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
universalName STRING

Version

Availability: from Vectorworks 2021