VS:IntersectSurface/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した図形で図形を抜き取ります。ただし、グループ図形やシンボル図形にはこの機能は使えません。

FUNCTION IntersectSurface(
s1 :HANDLE;
s2 :HANDLE) : HANDLE;
def vs.IntersectSurface(s1, s2):
    return HANDLE

Parameters

s1 HANDLE 図形1のハンドル
s2 HANDLE 図形2のハンドル

Return Value

抜き取った図形のハンドルを返します。

Example

PROCEDURE Example;
VAR
	h1, h2, h3, h4 :HANDLE;
	pt :VECTOR;
BEGIN
	h1 := NIL;
	WHILE h1 = NIL DO BEGIN
		Message('Pick the first object...');
		GetPt(pt.x, pt.y);
		h1 := PickObject(pt.x, pt.y);
	END;
	h2 := NIL;
	WHILE h2 = NIL DO BEGIN
		Message('Pick the second object...');
		GetPt(pt.x, pt.y);
		h2 := PickObject(pt.x, pt.y);
	END; 

	{Capture the handle of the next object.}
   	h3 := NextObj(h2);

	{Now create the intersection surface(s).}
	h4 := IntersectSurface(h1, h2);

	{Now find the intersection surface(s).}
	WHILE h4 <> h3 DO BEGIN
		SetFPat(h4, 3);
		h4 := NextObj(h4);
	END;
	ClrMessage;
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks8.5