VS:IFC SetIFCEntity
From Vectorworks Developer
.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix
Description
This function creates and attaches to hObject an IFC Record with the given IFC entity.FUNCTION IFC_SetIFCEntity(
hObject :HANDLE;
inStrIfcName :STRING) : BOOLEAN;
def vs.IFC_SetIFCEntity(hObject, inStrIfcName): return BOOLEAN
Parameters
hObject HANDLE Handle to object inStrIfcName STRING Name of the IFC entity
Return Value
TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name.Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one.
Example
Assume we have an object, which we want to be exported as furniture:VectorScript
IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’);
Python
ok = vs.IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’)