VS:IFC GetIFCEntity2

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the IFC entity type for an object by IFC record and IFC Data Mapping plus the type of the IFC record

FUNCTION IFC_GetIFCEntity2(
hObject :HANDLE;
VAR outType :INTEGER;
VAR outStrNameRec :STRING;
VAR outStrNameMap :STRING) : BOOLEAN;
def vs.IFC_GetIFCEntity2(hObject):
    return (BOOLEAN, outType, outStrNameRec, outStrNameMap)

Parameters

hObject HANDLE
outType INTEGER
outStrNameRec STRING
outStrNameMap STRING

Version

Availability: from Vectorworks 2018