VS:IFC GetEntityProp2

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the property value, its type and if the value comes from mapping or by instance.

FUNCTION IFC_GetEntityProp2(
hObject :HANDLE;
propertyName :STRING;
VAR outPropValue :STRING;
VAR outType :INTEGER;
VAR outMap :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityProp2(hObject, propertyName):
    return (BOOLEAN, outPropValue, outType, outMap)

Parameters

hObject HANDLE
propertyName STRING
outPropValue STRING
outType INTEGER
outMap INTEGER

Version

Availability: from Vectorworks 2018