VS:IFC GetEntityProp
From Vectorworks Developer
.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix
Description
Gets the value and type of a selected property from the IFC entity.FUNCTION IFC_GetEntityProp(
hObject :HANDLE;
inStrPropName :STRING;
VAR outStrPropValue :STRING;
VAR outTypeSelect :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityProp(hObject, inStrPropName): return (BOOLEAN, outStrPropValue, outTypeSelect)
Parameters
hObject HANDLE Handle to object inStrPropName STRING Name of the property outStrPropValue STRING Value of the property outTypeSelect INTEGER Type of the property
Return Value
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the property.outTypeSelect – value depends on the property type: 1 – identifier, 2 – double, 3 – boolean, 4 – integer, 5 – number (same as double), 6 – logical, 7 – string, 8 – enu-meration, 9 – select value
Example
VectorScript
PROCEDURE Test; VAR strPropValue: STRING; hExtrude : HANDLE; iType : INTEGER; ok : BOOLEAN; BEGIN hExtrude:= FSActLayer; ok := IFC_GetEntityProp(hExtrude, 'PredefinedType', strPropValue, iType); AlrtDialog(Concat(strPropValue, ' , ', iType)); END; RUN(Test);
Python
hExtrude = vs.FSActLayer() ok, strPropValue, iType = vs.IFC_GetEntityProp(hExtrude, 'PredefinedType') vs.AlrtDialog(strPropValue + ' , ' + str(iType))