VS:IFC GetEntityColor

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the default color for an IFC entity type

FUNCTION IFC_GetEntityColor(
inStrIfcType :STRING;
VAR outRed :INTEGER;
VAR outGreen :INTEGER;
VAR outBlue :INTEGER;
VAR outTransp :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityColor(inStrIfcType):
    return (BOOLEAN, outRed, outGreen, outBlue, outTransp)

Parameters

inStrIfcType STRING IFC Entity type.
outRed INTEGER Out parameter. Red Value of RGB color model.
outGreen INTEGER Out parameter. Green Value of RGB color model.
outBlue INTEGER Out parameter. Blue Value of RGB color model.
outTransp INTEGER Out parameter. Transepransy value.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	red   : INTEGER;
        green : INTEGER;
        blue  : INTEGER;
        transp: INTEGER;
	ok    : BOOLEAN;
begin
	ok := IFC_GetEntityColor('IfcWall', red, green, blue, transp);
end;

Run(Test);

Python

ok = vs.IFC_GetEntityColor('IfcWall', red, green, blue, transp)

Version

Availability: from Vectorworks 2014