VS:GetViewMatrix/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

レイヤやビューポートの見る方向を返します。

FUNCTION GetViewMatrix(
objectHandle :HANDLE;
VAR offset :POINT3D;
VAR rotationXAng :REAL;
VAR rotationYAng :REAL;
VAR rotationZAng :REAL) : BOOLEAN;
def vs.GetViewMatrix(objectHandle):
    return (BOOLEAN, offset, rotationXAng, rotationYAng, rotationZAng)

Parameters

objectHandle HANDLE
offset POINT3D
rotationXAng REAL
rotationYAng REAL
rotationZAng REAL

Version

利用可能バージョン: VectorWorks10.5