VS:GetVSVar

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This is python only function. The function stores a named VectorScript variable value into the python variable.

This function work in the context when a VectorScript executes a python sub-script and allows data communication between the two languages. See VS:SetVSVar for the reverse data transfer.

This function is useful when using PythonExecute or PythonBeginContext

def vs.GetVSVar(vsName):
    return Any

Parameters

vsName STRING The name of the VectorScript variable that will provide the value to be returned.

Return Value

Returns the value of the named VectorScript variable. The type will depend on the actual variable. See the remarks of VS:SetVSVar for more info.

Example

See VS:PythonExecute.

Version

Availability: from Vectorworks 2014

See Also

VS:SetVSVar | VS:PythonExecute | VS:PythonBeginContext

[[VS:SetVSVar]] | [[VS:PythonExecute]] | [[VS:PythonBeginContext]]