VS:GetVPClOvrdFillFore
From Vectorworks Developer
.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix
Description
Fetches the fill foreground color of the class override. The color is returned as three RGB components in the range 0~65535.PROCEDURE GetVPClOvrdFillFore(
viewportHandle :HANDLE;
className :STRING;
VAR colorRV :LONGINT;
VAR colorGV :LONGINT;
VAR colorBV :LONGINT);
def vs.GetVPClOvrdFillFore(viewportHandle, className): return (colorRV, colorGV, colorBV)
Parameters
viewportHandle HANDLE The viewport handle. className STRING The name of the class. colorRV LONGINT Red color value. colorGV LONGINT Green color value. colorBV LONGINT Blue color value.
Return Value
True if the viewport has an override for the specified class.False if it does not have an override or the class or viewport was invalid.
Version
Availability: from Vectorworks 2014See Also
VS Functions:VS Functions:
[[VS:SetVPClOvrdFillFore]]