VS:GetVPClOvrdFillBack

From Vectorworks Developer
Jump to: navigation, search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Fetches the fill background color of the class override. The color is returned as three RGB components in the range 0~65535.
PROCEDURE GetVPClOvrdFillBack(
viewportHandle  :HANDLE;
className  :STRING;
VAR colorRV  :LONGINT;
VAR colorGV  :LONGINT;
VAR colorBV  :LONGINT);
def vs.GetVPClOvrdFillBack(viewportHandle, className):
    return (colorRV, colorGV, colorBV)

Parameters

viewportHandle HANDLE Handle to the viewport.
className STRING Name of class.
colorRV LONGINT Returns red color component.
colorGV LONGINT Returns green color component.
colorBV LONGINT Returns blue color component.

Return Value

True if the viewport has an override for the specified class.

False if it does not have an override or the class or viewport was invalid.

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:SetVPClOvrdFillBack

VS Functions: [[VS:SetVPClOvrdFillBack]]
Personal tools
NamespacesFFFF

Variants
Actions
Advanced Search
See Also
Navigation
Toolbox