VS:GetTopPlan2DComp

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the 2D component that is shown in Top/Plan view for a symbol definition or plug-in object.


Table - components

Constant component
0 Top
1 Top and Bottom Cut
FUNCTION GetTopPlan2DComp(
objectHandle :HANDLE) : INTEGER;
def vs.GetTopPlan2DComp(objectHandle):
    return INTEGER

Parameters

objectHandle HANDLE Handle to the object.

Return Value

Returns the 2D component that is shown in Top/Plan view for a symbol definition or plug-in object.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:SetTopPlan2DComp | VS:Get2DComponentGroup | VS:Set2DComponentGroup

VS Functions:

[[VS:SetTopPlan2DComp]] | [[VS:Get2DComponentGroup]]

| [[VS:Set2DComponentGroup]]