VS:GetStoryBoundDataFromChoiceString/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ストーリの高さ基準選択ストリングから、ストーリの高さ基準データを返します。

PROCEDURE GetStoryBoundDataFromChoiceString(
choiceString :STRING;
VAR boundType :INTEGER;
VAR boundStory :INTEGER;
VAR layerLevelType :STRING);
def vs.GetStoryBoundDataFromChoiceString(choiceString):
    return (boundType, boundStory, layerLevelType)

Parameters

choiceString STRING ストーリの高さ基準の選択ストリング
boundType INTEGER 高さ基準のタイプ : 0 - デフォルトの壁の高さ; 1 - レイヤ高さ Z; 2 - 高さ基準.
boundStory INTEGER 高さ基準のタイプ boundType = 2 の場合、0 : 図形の高さ基準; 1 : 上のストーリ; 2 : 下のストーリ
layerLevelType STRING レイヤタイプ

Version

利用可能バージョン: Vectorworks 2012

See Also

関連関数:

VS:GetStoryBoundChoiceStrings | VS:GetChoiceStringFromStoryBoundData

関連関数:

[[VS:GetStoryBoundChoiceStrings]]

| [[VS:GetChoiceStringFromStoryBoundData]]