VS:GetStoryBoundDataFromChoiceString

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the story bound data from a story bound choice string.

PROCEDURE GetStoryBoundDataFromChoiceString(
choiceString :STRING;
VAR boundType :INTEGER;
VAR boundStory :INTEGER;
VAR layerLevelType :STRING);
def vs.GetStoryBoundDataFromChoiceString(choiceString):
    return (boundType, boundStory, layerLevelType)

Parameters

choiceString STRING The choice string that represents the story bound data.
boundType INTEGER Returns the bounding type: 0 - DefaultWallHeight; 1 - LayerZ; 2 - Story.
boundStory INTEGER Returns the story identified by 'boundType' = (2 - Story). If 'boundStory' = 0 then it is this story (the object's story); If 'boundStory' = 1 then it is the story above; If 'boundStory' = 2 then it is the story below.
layerLevelType STRING Returns the layer type which defines this bound.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetStoryBoundChoiceStrings | VS:GetChoiceStringFromStoryBoundData

VS Functions:

[[VS:GetStoryBoundChoiceStrings]]

| [[VS:GetChoiceStringFromStoryBoundData]]