VS:GetSelectedChoiceInfo/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

選択されている項目の番号と文字列を返します。

PROCEDURE GetSelectedChoiceInfo(
dialogID :LONGINT;
componentID :LONGINT;
startIndex :INTEGER;
VAR outSelectedIndex :INTEGER;
VAR outSelectedChoiceText :STRING);
def vs.GetSelectedChoiceInfo(dialogID, componentID, startIndex):
    return (outSelectedIndex, outSelectedChoiceText)

Parameters

dialogID LONGINT ダイアログ番号
componentID LONGINT アイテム番号
startIndex INTEGER 検索開始項目番号
outSelectedIndex INTEGER 選択されている項目の番号、-1の場合選択されていない。
outSelectedChoiceText STRING 選択されている項目の文字列

Version

利用可能バージョン: Vectorworks 2010