VS:GetScriptResource

From Vectorworks Developer
Jump to: navigation, search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return the script text of the specified script resource.
FUNCTION GetScriptResource(
scriptName  :STRING;
VAR script  :DYNARRAY[] OF CHAR;
VAR python  :BOOLEAN) : BOOLEAN;
def vs.GetScriptResource(scriptName):
    return (BOOLEAN, script, python)

Parameters

scriptName STRING The script name identifying the resource.
script DYNARRAY[] of CHAR Return the script text.
python BOOLEAN Return if the script text is a python script.

Return Value

Return TRUE if the creation was successful. The routine will fail if script with the specified name does't exist.

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:CreateScriptResource | VS:SetScriptResource | VS:OpenScriptResPal

VS Functions:

[[VS:CreateScriptResource]] | [[VS:SetScriptResource]]

| [[VS:OpenScriptResPal]]
Personal tools
NamespacesFFFF

Variants
Actions
Advanced Search
See Also
Navigation
Toolbox