VS:GetPseudoIndFromDash

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Supplies a pseudo index for a dashed style. The returned index is not guaranteed to produce the same line type from file to file, nor even in the same file if line types change.

Returns TRUE if successful.

FUNCTION GetPseudoIndFromDash(
dashStyle :LONGINT;
VAR outPseudoIndex :INTEGER) : BOOLEAN;
def vs.GetPseudoIndFromDash(dashStyle):
    return (BOOLEAN, outPseudoIndex)

Parameters

dashStyle LONGINT Negative internal index of a dashed line type.
outPseudoIndex INTEGER Pseudo index (a negative number) corresponding to the dash style. The psuedo index is not guaranteed to produce the same line across files (or even in the same file if line types are changed).

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:GetDashFromPseudoInd | VS:BeginMultDashConvert | VS:EndMultDashConvert

VS Functions:

[[VS:GetDashFromPseudoInd]] | [[VS:BeginMultDashConvert]]

| [[VS:EndMultDashConvert]]