VS:GetPartTypeInfo

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get all part information for the specified sub-object. The sub-object must be an object that was tagged as a part.

FUNCTION GetPartTypeInfo(
objectHandle :HANDLE;
VAR partTypeName :STRING;
VAR dataID :LONGINT;
VAR uniqueInstanceName :STRING) : BOOLEAN;
def vs.GetPartTypeInfo(objectHandle):
    return (BOOLEAN, partTypeName, dataID, uniqueInstanceName)

Parameters

objectHandle HANDLE The sub-object handle.
partTypeName STRING The name of the part type.
dataID LONGINT The numeric value assigned to this part instance
uniqueInstanceName STRING The unique name assigned to this part instance.

Return Value

Return TRUE if the specified object is a part and the part information was retrieved successfully.

Version

Availability: from Vectorworks 2022

See Also

VS Functions:

VS:TagSubObjectAsPart | VS:IsObjectTaggedAsPart | VS:GetPartTypeName

VS Functions:

[[VS:TagSubObjectAsPart]] | [[VS:IsObjectTaggedAsPart]]

| [[VS:GetPartTypeName]]