VS:GetPartDataID

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return the numeric value assigned to this part instance represented by the specified sub-object.

The sub-object must be an object that was tagged as a part.

FUNCTION GetPartDataID(
objectHandle :HANDLE) : LONGINT;
def vs.GetPartDataID(objectHandle):
    return LONGINT

Parameters

objectHandle HANDLE The sub-object handle.

Return Value

The numeric value assigned to this part instance.

Version

Availability: from Vectorworks 2022