VS:GetParametricRecord

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the handle to the parametric record attached the referenced object.


Parametric record is a hidden record format containing the parameter values of the parametric object.
Only parametric objects have parametric records.

FUNCTION GetParametricRecord(
h :HANDLE) : HANDLE;
def vs.GetParametricRecord(h):
    return HANDLE

Parameters

h HANDLE Handle to a parametric object

Return Value

Returns a handle to the record, or NIL if the record doesn't exist (e.g. not a parametric object passed)

Version

Availability: from Vectorworks 2011