VS:GetParamStyleType

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the style type (by instance or by style) for a parameter.

FUNCTION GetParamStyleType(
hStyle :HANDLE;
paramName :STRING) : INTEGER;
def vs.GetParamStyleType(hStyle, paramName):
    return INTEGER

Parameters

hStyle HANDLE Handle to a symbol containing a plug-in style.
paramName STRING Universal name of a parameter to check for style type.

Return Value

0 = Parametrer is an instance parameter

1 = Parameter is a style parameter.

If the object in unstyled or the parameter name if not found 0 will be returned and should be treated as an instance parameter.

Version

Availability: from Vectorworks 2017