VS:GetOwnerDrawnControlObjectInfo

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

?

FUNCTION GetOwnerDrawnControlObjectInfo(
dialogID :LONGINT;
componentID :LONGINT;
iObjectID :INTEGER;
VAR iDrawPadObjectType :INTEGER;
VAR bDraggable :BOOLEAN;
VAR bDragging :BOOLEAN;
VAR bSelectable :BOOLEAN;
VAR bSelected :BOOLEAN;
VAR bHasFill :BOOLEAN) : BOOLEAN;
def vs.GetOwnerDrawnControlObjectInfo(dialogID, componentID, iObjectID):
    return (BOOLEAN, iDrawPadObjectType, bDraggable, bDragging, bSelectable, bSelected, bHasFill)

Parameters

dialogID LONGINT
componentID LONGINT
iObjectID INTEGER
iDrawPadObjectType INTEGER
bDraggable BOOLEAN
bDragging BOOLEAN
bSelectable BOOLEAN
bSelected BOOLEAN
bHasFill BOOLEAN

Version

Availability: from VectorWorks12.5