VS:GetEntityMatrix/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

プレイナー図形の平面マトリックスを取得します。

FUNCTION GetEntityMatrix(
objectHandle :HANDLE;
VAR offset :POINT3D;
VAR rotationXAngle :REAL;
VAR rotationYAngle :REAL;
VAR rotationZAngle :REAL) : BOOLEAN;
def vs.GetEntityMatrix(objectHandle):
    return (BOOLEAN, offset, rotationXAngle, rotationYAngle, rotationZAngle)

Parameters

objectHandle HANDLE マトリックスを取得したいオブジェクト
offset POINT3D 現在の書類の単位での平面のオフセット
rotationXAngle REAL X軸周りの平面の回転角度
rotationYAngle REAL Y軸周りの平面の回転角度
rotationZAngle REAL Z軸周りの平面の回転角度

Return Value

渡されたオブジェクトがプレイナー図形の場合にはtrueを返します。

Version

利用可能バージョン: Vectorworks 2011