VS:GetDlgCtrlWidthStdCh

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the width in standard characters for dialog control creation.


The width is different than the number of symbols (Len) as in some languages (Japanese for example) the symbols are very different in size on the dialog.

E.g. CreateStaticText

FUNCTION GetDlgCtrlWidthStdCh(
str :DYNARRAY[] of CHAR) : INTEGER;
def vs.GetDlgCtrlWidthStdCh(str):
    return INTEGER

Parameters

str DYNARRAY[] of CHAR The string used to calculate the std character count.

Return Value

Return the number of std characters in the input string.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:CreateStaticText | VS:CreateCenteredStaticText | VS:CreateStyledStatic | VS:CreateEditInteger | VS:CreateEditReal | VS:CreateEditText | VS:CreateEditTextBox | VS:CreateListBox | VS:CreateListBoxN | VS:CreateLB | VS:CreatePullDownMenu | VS:CreateEnhancedPullDownMenu | VS:CreateColorPopup | VS:CreatePullDownMenuGroupBox | VS:CreateTreeControl | VS:CreateClassPullDownMenu | VS:CreateDesignLayerPullDownMenu | VS:CreateSheetLayerPullDownMenu

VS Functions:

[[VS:CreateStaticText]] | [[VS:CreateCenteredStaticText]] | [[VS:CreateStyledStatic]] | [[VS:CreateEditInteger]] | [[VS:CreateEditReal]] | [[VS:CreateEditText]] | [[VS:CreateEditTextBox]] | [[VS:CreateListBox]] | [[VS:CreateListBoxN]] | [[VS:CreateLB]] | [[VS:CreatePullDownMenu]] | [[VS:CreateEnhancedPullDownMenu]] | [[VS:CreateColorPopup]] | [[VS:CreatePullDownMenuGroupBox]] | [[VS:CreateTreeControl]] | [[VS:CreateClassPullDownMenu]] | [[VS:CreateDesignLayerPullDownMenu]]

| [[VS:CreateSheetLayerPullDownMenu]]