VS:GetDisplayWith2DComp

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets whether a 3D object in a symbol definition or plug-in object is shown when the specified 2D component is shown.


                   Table - 2D components

2D component Constant
Not Set 0
Top 1
Bottom 2
Top and Bottom Cut 3
Front 4
Back 5
Front and Back Cut 6
Left 7
Right 8
Left and Right Cut 9

FUNCTION GetDisplayWith2DComp(
objectHandle :HANDLE;
component :INTEGER) : BOOLEAN;
def vs.GetDisplayWith2DComp(objectHandle, component):
    return BOOLEAN

Parameters

objectHandle HANDLE 3D object handle.
component INTEGER 2D component.

Return Value

Returns whether a 3D object in a symbol definition or plug-in object is shown when the specified 2D component is shown.

Version

Availability: from Vectorworks 2019