VS:GetDefGenStoryBound

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This will get the default story bound for a plugin that has the kObjXPropSupportGenericStoryLevel property.

The bound information returned is only valid when the return value of the function is TRUE.

FUNCTION GetDefGenStoryBound(
format :HANDLE;
VAR boundType :INTEGER;
VAR boundStory :INTEGER;
VAR layerLevelType :STRING;
VAR offset :REAL) : BOOLEAN;
def vs.GetDefGenStoryBound(format):
    return (BOOLEAN, boundType, boundStory, layerLevelType, offset)

Parameters

format HANDLE Handle of the parametric's format
boundType INTEGER Bounding type: 0 - LayerZ; 1 - DefaultWallHeight; 2 - Story
boundStory INTEGER The story for the bound. If 'boundStory' = 0 then it is the object's story. If 'boundStory' = 1 then it is the story above. If 'boundStory' = -1 then it is the story below.
layerLevelType STRING The layer type which defines this bound (e.g. "Ceiling").
offset REAL The offset distance from the specified bound story.

Return Value

Returns TRUE if the default bounds were obtained; FALSE if the input format was not a format associated with a plugin that supports the generic PIO bound (i.e. has the kObjXPropSupportGenericStoryLevel property set).

Version

Availability: from Vectorworks 2017