VS:GetDashFromPseudoInd

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the dash style that corresponds to the pseudo index and returns the style's internal index. Returns TRUE if successful.


FUNCTION GetDashFromPseudoInd(
pseudoIndex :INTEGER;
VAR outDashStyle :LONGINT) : BOOLEAN;
def vs.GetDashFromPseudoInd(pseudoIndex):
    return (BOOLEAN, outDashStyle)

Parameters

pseudoIndex INTEGER Pseudo index (negative value) for which a dash style is requested.
outDashStyle LONGINT Negative internal index of a dashed line type corresponding to the psuedo index.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:GetPseudoIndFromDash | VS:BeginMultDashConvert | VS:EndMultDashConvert

VS Functions:

[[VS:GetPseudoIndFromDash]] | [[VS:BeginMultDashConvert]]

| [[VS:EndMultDashConvert]]