VS:GetDLCompPenStylesN

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the left and right side pen styles of the component at index in the Double Line Preferences.

FUNCTION GetDLCompPenStylesN(
index :INTEGER;
VAR penStyleLeft :LONGINT;
VAR penStyleRight :LONGINT) : BOOLEAN;
def vs.GetDLCompPenStylesN(index):
    return (BOOLEAN, penStyleLeft, penStyleRight)

Parameters

index INTEGER The index of the component.
penStyleLeft LONGINT Returns the pen style of the component's left line. Positive values for patters, negative values for line types.
penStyleRight LONGINT Returns the pen style of the component's right line. Positive values for patterns, negative values for line types.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:SetDLCompPenStylesN

VS Functions: [[VS:SetDLCompPenStylesN]]