VS:GetComponentFunction

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the function of a component in an object.

FUNCTION GetComponentFunction(
object :HANDLE;
componentIndex :INTEGER;
VAR func :INTEGER) : BOOLEAN;
def vs.GetComponentFunction(object, componentIndex):
    return (BOOLEAN, func)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
func INTEGER Returns the function of the component. 0 - Other 1 - Load-Bearing 2 - Insulation 3 - Inner Finish 4 - Outer Finish 5 - Air Gap

Version

Availability: from Vectorworks 2018

See Also

VS Functions:

VS:SetComponentFunction

VS Functions: [[VS:SetComponentFunction]]