VS:GetAttributeValue

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of the attribute corresponding to the specified element and attribute name. The parameter elementPath is specified as a path of element names. Returns attribute not found error if the attribute is not found.

FUNCTION GetAttributeValue(
XMLHandle :LONGINT;
elementPath :STRING;
attribute :STRING;
VAR value :STRING) :INTEGER;
def vs.GetAttributeValue(XMLHandle, elementPath, attribute):
    return (INTEGER, value)

Parameters

XMLHandle LONGINT
elementPath STRING
attribute STRING
value STRING Output parameter.

Version

Availability: from All Versions

This is drop-in function.