VS:Get2DComponentGroup

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified 2D component group of a symbol definition or plug-in object or NULL if the group does not exist.


Table - 2D components

Constant 2D component
0 Not Set
1 Top
2 Bottom
3 Top and Bottom Cut
4 Front
5 Back
6 Front and Back Cut
7 Left
8 Right
9 Left and Right Cut
FUNCTION Get2DComponentGroup(
objectHandle :HANDLE;
component :INTEGER) : HANDLE;
def vs.Get2DComponentGroup(objectHandle, component):
    return HANDLE

Parameters

objectHandle HANDLE Handle to the object.
component INTEGER 2D component.

Return Value

Returns a HANDLE to the specified 2D component group.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Set2DComponentGroup | VS:SetTopPlan2DComp | VS:GetTopPlan2DComp

VS Functions:

[[VS:Set2DComponentGroup]] | [[VS:SetTopPlan2DComp]]

| [[VS:GetTopPlan2DComp]]