VS:FindFile

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Find a file by searching the folder selector (whichPath) plus the relative file path. Searches the user folder, workgroup folders, and the app folder.

FUNCTION FindFile(
whichPath :INTEGER;
relFilePath :DYNARRAY[] of CHAR;
VAR outPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.FindFile(whichPath, relFilePath):
    return (BOOLEAN, outPath)

Parameters

whichPath INTEGER
relFilePath DYNARRAY[] of CHAR
outPath DYNARRAY[] of CHAR

Remarks

--~~~~June 4, 2022. Pat Stanford. OutPath MUST be a DynArray of Char. A String crashes VW to the desktop. This was also documented by Paolo in VW2020 in February 2020 on the VW Forum.

Version

Availability: from Vectorworks 2015