VS:EXL GetCellAlignment

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get cell horizontal and vertical alignment, text angle, is text wrapped and is inconsistency found.

FUNCTION EXL_GetCellAlignment(
sheetIndex :INTEGER;
cellRow :INTEGER;
cellColumn :INTEGER;
VAR outAlignmentH :INTEGER;
VAR outAlignmentV :INTEGER;
VAR outTextAngle :INTEGER;
VAR outWrapTextFlag :BOOLEAN;
VAR outInconsistencyFound :BOOLEAN) : BOOLEAN;
def vs.EXL_GetCellAlignment(sheetIndex, cellRow, cellColumn):
    return (BOOLEAN, outAlignmentH, outAlignmentV, outTextAngle, outWrapTextFlag, outInconsistencyFound)

Parameters

sheetIndex INTEGER
cellRow INTEGER
cellColumn INTEGER
outAlignmentH INTEGER
outAlignmentV INTEGER
outTextAngle INTEGER
outWrapTextFlag BOOLEAN
outInconsistencyFound BOOLEAN

Version

Availability: from Vectorworks 2021