VS:Distance/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

指定した2点間の距離を返します。

FUNCTION Distance(
x1 :REAL;
y1 :REAL;
x2 :REAL;
y2 :REAL) : REAL;
def vs.Distance(x1, y1, x2, y2):
    return REAL

Parameters

x1 REAL 1点目のX座標
y1 REAL 1点目のY座標
x2 REAL 2点目のX座標
y2 REAL 2点目のY座標

Example

d:=Distance(0,2,4,5);
{returns the distance between (0,2) and (4,5)}

Version

利用可能バージョン: MiniCAD

See Also

関連関数:

VS:Norm

関連関数: [[VS:Norm]]