VS:DBDocGetColumns/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

指定されたテーブルデータのコロンで区切られたリストをストリング表示で返します。

FUNCTION DBDocGetColumns(
database :STRING;
table :STRING;
VAR outNames :DYNARRAY[] of CHAR;
VAR outTypes :DYNARRAY[] of CHAR;
VAR outCanBeKey :DYNARRAY[] of CHAR;
VAR outIsKey :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.DBDocGetColumns(database, table):
    return (BOOLEAN, outNames, outTypes, outCanBeKey, outIsKey)

Parameters

database STRING
table STRING
outNames DYNARRAY[] of CHAR
outTypes DYNARRAY[] of CHAR
outCanBeKey DYNARRAY[] of CHAR
outIsKey DYNARRAY[] of CHAR

Version

利用可能バージョン: Vectorworks 2011