VS:CreateText/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

現在のペン位置に文字図形を作成します。

PROCEDURE CreateText(
theText :DYNARRAY[] of CHAR);
def vs.CreateText(theText):
    return None

Parameters

theText DYNARRAY[] of CHAR 文字列

Example

PROCEDURE Example;
VAR
	Txt   :ARRAY [1..100] of STRING;
	Outpt :DYNARRAY[] of CHAR;
	i     :INTEGER;
BEGIN
	FOR i := 1 TO 5 DO txt[i] := 'asdf';
	i := 2;
	Outpt := Txt[1];
	WHILE Txt[i] <> '' DO BEGIN
		OutPt := Concat(Outpt, Chr(13), Txt[i]);
		i := i + 1;
	END;
	Layer('Text');
	CreateText(Outpt);
	Layer('Layer-1');
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks8.0

See Also

関連関数:

VS:BeginText | VS:EndText

関連関数:

[[VS:BeginText]]

| [[VS:EndText]]