VS:CreateImgFromSymbolN

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates an image from the specified symbol in the specified rendering mode and view, and uses the specified component of the image. Table - Render Modes

Render Mode Constant
Wireframe 0
Unshaded Polygon 2
Shaded Polygon 3
Shaded Polygon No Lines 4
Final Shaded Polygon 5
Hidden Line 6
Dashed Hidden Line 7
OpenGL 11
Fast RenderWorks 12
Fast RenderWorks with Shadows 13
Final Quality RenderWorks 14
Custom RenderWorks 15
Artistic RenderWorks 17
Sketch 18

Table - Views
View Constant
Top/Plan 2
Front 3
Back 4
Left 5
Right 6
Top 7
Bottom 8
Right Isometric 9
Left Isometric 10
Right Rear Isometric 11
Left Rear Isometric 12
Bottom Right Isometric 13
Bottom Left Isometric 14
Bottom Right Rear Isometric 15
Bottom Left Rear Isometric 16

Table - Components
Component Constant
"3D" 0
"2D" 1
"2D Cut" 2
"Not set" 4

FUNCTION CreateImgFromSymbolN(
symbolName :STRING;
width :INTEGER;
height :INTEGER;
margin :INTEGER;
renderMode :INTEGER;
view :INTEGER;
component :INTEGER) : HANDLE;
def vs.CreateImgFromSymbolN(symbolName, width, height, margin, renderMode, view, component):
    return HANDLE

Parameters

symbolName STRING The name of the symbol to display.
width INTEGER The width of the symbol to display.
height INTEGER The height of the symbol to display.
margin INTEGER The margin of the symbol to display.
renderMode INTEGER The render mode in which to display the symbol.
view INTEGER The standard view in which to display the symbol.
component INTEGER Image component to use.

Return Value

Returns the handle to the newly create image resource if successful; NULL otherwise.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:CreateImgFromSymbol

VS Functions: [[VS:CreateImgFromSymbol]]