VS:CreateEditPassword

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates an password text field control in a dialog layout.

PROCEDURE CreateEditPassword(
dialogID :LONGINT;
itemID :LONGINT;
widthInStdChar :LONGINT);
def vs.CreateEditPassword(dialogID, itemID, widthInStdChar):
    return None

Parameters

dialogID LONGINT The index of the dialog layout containing the control.
itemID LONGINT The index that will identify the control item.
widthInStdChar LONGINT The width of the displayed text in standard character count. See GetDlgCtrlWidthStdCh.

Example

PROCEDURE Example;
VAR
	dialog1 :INTEGER;
	result  :INTEGER;
PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
END;
BEGIN
	dialog1 := CreateLayout('Example Dialog', FALSE, 'OK', 'Cancel');
	CreateEditPassword(dialog1, 4, 16);
	SetFirstLayoutItem(dialog1, 4);
	result := RunLayoutDialog(dialog1, Dialog_Handler);
END;
RUN(Example);

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:GetDlgCtrlWidthStdCh

VS Functions: [[VS:GetDlgCtrlWidthStdCh]]